Sign in

What are the requirements for installing The Bug Genie?

Basic requirements

To install The Bug Genie, you need:

  • A web server with support for URL rewriting
  • PHP 5.3.10 or later (5.5.x recommended)
  • A supported relational database

Each of these requirements have different components or configurations which must be used, described below.

A web server with support for URL rewriting

To install The Bug Genie, you must have a web server which supports URL rewriting. Supported web-servers are:

  • Apache 2.x
  • Nginx
  • IIS 7

Step-by-step installation guides are available for each server type in the knowledge base and in our community help sections.

PHP 5.3.10 or later

The Bug Genie uses many advanced functions in PHP, and takes advantage of much of the newer features in PHP 5.3. It cannot be installed or used on a PHP setup older than PHP 5.3.10, but you should try and use the latest available PHP version. The Bug Genie currently supports all PHP versions between 5.3.10 and 5.5.13 (the latest available PHP version at the time of writing).

In addition to this, the following PHP modules must be installed and enabled:

  • php-json
  • php-gd
  • php-curl
  • php-pdo - also a driver for the database you want to use

A supported relational database

The Bug Genie requires a supported relational database to function properly. The following databases are supported:

  • MySQL / MariaDB
  • PostgreSQL
  • MSSQL
Get started
About
Resources
Connect
The Bug Genie - friendly issue tracking and project management since 2002